Power/Speed issue

This forum is for comments and the exchange of information relating to Trojan Boats and boating. Please do not post used parts or boats For Sale in this area. For general, non-boating topics please use our "General Discussions" section.

Note: Negative or inflammatory postings will not be tolerated.

Moderators: BeaconMarineBob, Moderator, BeaconMarineDon

User avatar
goros
Registered user
Posts: 25
Joined: Thu May 09, 2013 9:01 am

Re: Power/Speed issue

Post by goros »

Image

Yesterday the boat hit the water but the sea was rough for testing. This afternoon I will try again.

A greeting
goros
Trojan F32 321 8853
España

User avatar
Commissionpoint
Active User
Posts: 1197
Joined: Wed Oct 05, 2011 11:59 pm
Location: Diamond Point on Lake George, NY
Contact:

Re: Power/Speed issue

Post by Commissionpoint »

srokag44 wrote: There are usually 50 or so manatees hanging around because of the warmer water. I'm guessing that it is very bad for growth rate.
We have those too when August rolls around. They are usually from Jersey and wear bikinis. :shock:

They're bad for something, but not my props. I sure as hell hope one doesn't try to cling onto my shaft though, definately bad for the growth rate. :wink:

I'll post pics this fall when I haul out. Cold fresh water keeps things real clean.
1978 F-32 "Eclipse"
Merc 305 SBC's
1.52:1 Borg Warners

1983 Correct Craft
Commander 351 Ford (PCM)
1:1 Borg Warner

There are 350 different varieties of shark, not counting loan or pool.

larryeddington
2020 Forum Support
2020 Forum Support
Posts: 1851
Joined: Mon Sep 28, 2009 5:08 pm
Location: Canton, TX Boat on TEXOMA

Re: Power/Speed issue

Post by larryeddington »

after all this time the Phoenix is under full power. Both 318 are running perfectly. Best rpm was 3200 to 3300 both engines. Ran her hard for over an hour and same. Not sure of speed but definitely on plane. My assessment is I need the bottom pressure washed. Gonna wait a little while as I have some sensors to be installed in through the hull and will do it at same time. Fresh water on Lake Texoma. But it was a joy to run her with my son and we had a ball. At least now we are boating. For you northerners we still get regular unleaded at fuel dock, no alcohol in Gas, can't say the same for Larry. :D
Larry Eddington
1984 F-36 Tri Cabin "The Phoenix II"
1978 F-28 "The Phoenix"
Fish Master 2350 Bay Boat
9.5' Dink

User avatar
Paul
Active User
Posts: 1141
Joined: Fri Jun 10, 2005 1:02 pm
Location: Windsor Ont.

Re: Power/Speed issue

Post by Paul »

Hi Larry,

Did that set of controls work out OK for you?
Paul
"Cruise Control" 1978 F-26HT
"No Control" 2012 9' Grand RIB

larryeddington
2020 Forum Support
2020 Forum Support
Posts: 1851
Joined: Mon Sep 28, 2009 5:08 pm
Location: Canton, TX Boat on TEXOMA

Re: Power/Speed issue

Post by larryeddington »

Well I still have em, I disassembled and greased them and would work very well. But now I have another F28 on lake texoma. It has four different controls which all work. One of them is like the originals I have and one is like the one you sent me. I really will not need them but can return them to you or provide them to someone who is in need later, or save them if one of mine go down. One set on the new f28 is really weird, on topside throttle looks like bird wings, to way you can advance with one hand, Let me know if you want that set back.

Larry :D
Larry Eddington
1984 F-36 Tri Cabin "The Phoenix II"
1978 F-28 "The Phoenix"
Fish Master 2350 Bay Boat
9.5' Dink

User avatar
Paul
Active User
Posts: 1141
Joined: Fri Jun 10, 2005 1:02 pm
Location: Windsor Ont.

Re: Power/Speed issue

Post by Paul »

Don't need them back, just thought I'd see how you made out with them. Sounds like you may use them some day. I installed a new set of Morse controls in mine over the winter along with new cables. Unfortunately due to slow recovery I probably won't have the boat in the water to try them out until summer 2014.
Paul
"Cruise Control" 1978 F-26HT
"No Control" 2012 9' Grand RIB

larryeddington
2020 Forum Support
2020 Forum Support
Posts: 1851
Joined: Mon Sep 28, 2009 5:08 pm
Location: Canton, TX Boat on TEXOMA

Re: Power/Speed issue

Post by larryeddington »

As it turns out I have two f28 one now operational in the water, the other beside my barn, which, I am going to strip of all usable parts and cut up and bury with the backhoe. So will have pretty much backup parts for most everything. already salvaged the volt meters for lower helm and now all gauges work perfectly. Engines are purring. AC will freeze you out. next project is carb kit and raw water kit for Genny. Have those parts at my shop now for restoration.
Larry Eddington
1984 F-36 Tri Cabin "The Phoenix II"
1978 F-28 "The Phoenix"
Fish Master 2350 Bay Boat
9.5' Dink

Post Reply