Page 2 of 3

Re: Power/Speed issue

Posted: Tue May 14, 2013 12:17 pm
by sehord
Sounds like you were spinnig two big trash can lids back there.... hows your speed now?

Re: Power/Speed issue

Posted: Tue May 14, 2013 2:50 pm
by srokag44
I didn't even bother scraping the props. I have a broken wrist in a cast right now so that would've been quite a challenge. I plan on getting a haul out and bottom job in about a month. (Marinas are slammed right now and I want it to be a quick turnaround.)

Speed actually got much worse while motoring home because I had to run on one engine.... http://www.trojanboats.net/wforum/viewt ... f=1&t=7476

Re: Power/Speed issue

Posted: Tue May 14, 2013 3:10 pm
by RWS
srokag44 wrote:Sure enough there were a couple barnacles on the props and a lot of white squiggly looking growth. I'll post pictures I took with my underwater camera later tonight.

=====================================================

same thing happened to me in 2003.

props, shafts, tabs and struts.

It happened over a period of 7 days in the warm water in the canal.

NASTY !

Re: Power/Speed issue

Posted: Tue May 14, 2013 3:17 pm
by srokag44
The marina I keep the boat in is very isolated from the river so the water is very warm and very still. There are usually 50 or so manatees hanging around because of the warmer water. I'm guessing that it is very bad for growth rate.

Re: Power/Speed issue

Posted: Tue May 14, 2013 3:25 pm
by sehord
I have my 10 meter on a lift or I'd be in the same lot as you. I have a small lift for my sons 13' boston whaler also. I took his boat out so we could use it at the river last weekend, and didn't lift the lfit out of the water all week as the whaler was on a trailer until I could put it back in this past saturday. I lifted the lift and the wooden bunk boards are covered with thousands of tiny barnacles. Just one week with no protection and they boom. You hear so much talk of prop pitch and do people have the right size.... imagine how much out of whack all that growth does to a prop and running gear... drag drag drag.

Re: Power/Speed issue

Posted: Tue May 14, 2013 7:22 pm
by yorklyn
I have never coated my props with anything but the prop shop that did my shafts and rudders suggested spraying them with Pettit Barnical buster zinc paint. Has anyone ever tried something like that on there props with any success?????? It may help him limit future growth.

Re: Power/Speed issue

Posted: Tue May 14, 2013 10:08 pm
by srokag44
Here is what my props looked like:
Prop.jpg
Prop.jpg (29.98 KiB) Viewed 3062 times
There were a couple barnacles as well. Rudders and bottom looked similar.

Re: Power/Speed issue

Posted: Tue May 14, 2013 10:48 pm
by prowlersfish
yorklyn wrote:I have never coated my props with anything but the prop shop that did my shafts and rudders suggested spraying them with Pettit Barnical buster zinc paint. Has anyone ever tried something like that on there props with any success?????? It may help him limit future growth.

Good Stuff IMO

Re: Power/Speed issue

Posted: Wed May 15, 2013 4:55 am
by goros
sorry my ignorance but what are the props?

goros

Re: Power/Speed issue

Posted: Wed May 15, 2013 6:36 am
by prowlersfish
props = propellers

Re: Power/Speed issue

Posted: Wed May 15, 2013 9:24 am
by goros
propellers!!! en español = hélices

Thanks, now i can stand you fine

goros

Re: Power/Speed issue

Posted: Tue May 21, 2013 4:00 am
by goros
is posible that the swiming plataform dont let it to be plane ang get speed?

Image

goros

Re: Power/Speed issue

Posted: Fri May 24, 2013 7:09 am
by goros
good morning

this is what I have found to get my F32 to ground. I will make new blades in steel and much larger.

A greeting
goros

Image

Image

Image

Image

Image

Re: Power/Speed issue

Posted: Mon May 27, 2013 4:16 am
by goros
thought about your comments and the outcome of this weekend is as follows:

Image

Image

Image

Thanks for your helps
goros

Re: Power/Speed issue

Posted: Tue May 28, 2013 8:37 am
by sehord
Let us know how she does once you get back in the water....